Version 15.04 – The real release

The April release of Smap is finally available.   These release notes extend the previous notes for 15.04.

I had to add some more functionality which delayed its release a little, including:

  1. Compressing select multiple questions when exporting to XLS
  2. Authentication of emails sent as a notification of an event.

Compressing Select Multiple Questions

Smap Server has always exported the results of select multiple questions as 1 column per choice.  Each column contains a “1” or a “0” to indicate whether or not the choice was selected.  This is convenient for analysis but results in large unwieldily tables if your objective is to take the spreadsheet into a meeting and discuss its contents.  Hence a new compress select multiple option has been added to the XLS export.   This will put all the names of selected choices into a single column separated by a space.

Loading Select Multiple Values into a Survey from a CSV file

Having all the select multiple choices in a single column is also used to load select multiple values from a CSV file.  This allows you to export a survey with compressed select multiple questions, modify the options in a CSV file and reload them back into the survey.

Authenticating Email Users

When setting up email notifications you can now specify the user name and password of the email user to send the emails.  This should reduce the chance of email ending up in Spam and will allow you to store sent emails in the sent folder of that email account.  Details are in the operations guide.

Bugs

  1. Monitoring of notifications only showed notifications at the whole organisation level.  These are now shown per project or per survey.

Update 15.04.02

  1. Added more detail to the error message that is shown when you attempt to load tasks into a form that you have not explicitly marked as being allowed to get data from a CSV file.  The error message now directs you to the settings dialog.
  2. Added error message if there are no columns in the CSV file that match questions in the form.  Previously this just resulted in a generic internal system error.
  3. Added an error message if the CSV file to be loaded is not specified.
  4. Fixed bug preventing loading of instance name data
  5. Remove spaces at the beginning and end of values inside the CSV file.  These spaces would cause image files in the ZIP file not to be found

Update 15.04.03

  1. Fixed issue where tasks are not created from an existing survey if the locations of the existing survey are in a subform and the location is missing.

Update 15.04.04

  1. Fixed issue with adding task addresses and filtering tasks.

7 thoughts on “Version 15.04 – The real release

  1. jlsevillano

    I installed the last version. I uploaded by app and with form data, but smap server not create the tables to storage the information and in monitoring only can see in submitted (instances) the xml and appears: Not added to database Why? ws user is a superuser.

    Reply
    1. Neil Penman Post author

      “Not added to darabase” is shown as a status after the survey results have been received by the database and before the “subscriber” batch process writes the results to the database. Was there a problem running the subscriber? You can check subscriber logs for errors, further info is avsilable in the operations manual.

      Reply
      1. jlsevillano

        In subscriber_default_forward.log (no errors), but in subscriber_default_upload.log i have:
        Caused by: org.hibernate.exception.JDBCConnectionException: could not execute query
        Caused by: org.postgresql.util.PSQLException: An I/O error occured while sending to the backend.
        Caused by: java.net.SocketException: Broken pipe

        Any Idea?

        Reply
        1. Neil Penman Post author

          The upload log has errors when applying results to a local database. The forward log is only used when you are also forwarding results on to another database.

          That error doesn’t tell me much. Presumably there was another error that “broke the pipe”. Anyway good to hear its working.

          Reply
  2. jlsevillano

    Victory…running, but one thing. In a fresh installation (new ubuntu 14.04 LTS 64-bits). to complete the installation, in both, i must to run the setupDB.sql and results.sql manually.

    Reply

Leave a Reply to jlsevillano Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.